1 (изменено: Endeveral, 10-04-2020 15:32:40)

Тема: Ошибка при установке

День добрый.
После установки новой версии выдало ошибку при в ходе в админку
Fatal error: Access level to App\Entity\Doc\Document::__construct() must be public (as in class ZCL\DB\Entity) in /sites/***********/app/entity/doc/document.php on line 0
Версия пхп 7.1

2

Re: Ошибка при установке

надо  пхп 7.2 как минимум

3

Re: Ошибка при установке

минимум 7.2 а оптимально? что бы потом опять не извращаться?

4

Re: Ошибка при установке

пхп 7.4
вот такие ошибки
Deprecated: Array and string offset access syntax with curly braces is deprecated in /sites/*********/vendor/electrolinux/phpquery/phpQuery/phpQuery/phpQueryObject.php on line 1040

Deprecated: Array and string offset access syntax with curly braces is deprecated in /sites/*********/vendor/electrolinux/phpquery/phpQuery/phpQuery/phpQueryObject.php on line 1055

5

Re: Ошибка при установке

это  предупреждения об  устаревших функциях которые будут  выпилены в  8  версии.  Это  сторонняя  библиотека  надеюсь  обновят.
в настройках  пхп  надо  просто  убрать  сообщения  о  предупреждениях и должно  раьотать
или  использовать  версии  7.2  или  7.3

6

Re: Ошибка при установке

ок с этим понято, еще вопрос при подключении к опенкарту требует контрагента - а если их много как тогда?

7

Re: Ошибка при установке

это  контрагент  от  имени  которого  должны  поступать  заказы  в  систему
То есть  создайте  специального  виртуального  то есть  фейкового  контран=гента  и укажите  его  в  настройках

8

Re: Ошибка при установке

Вы имеете ввиду фейкового менеджера - но их много и ни какие с сайта не подтягиваются, ввожу существующего выдает ошибку

9

Re: Ошибка при установке

Спасибо - разобрался

10

Re: Ошибка при установке

ок
Поменял  библиотеку  чтобы  не  выкидывала предупреждения